Airhead admin changes delay
Incident Report for Airhead -
Resolved
The issue has been resolved and all changes have been completed.
Posted over 1 year ago. Jul 07, 2016 - 18:18 BST
Identified
We have identified an issue which will result in a delay in applying changes to permissions, noticeboards and group syncs. We are working on the issue and hope to have it resolved as soon as possible. All other Airhead components are operating normally.
Posted over 1 year ago. Jul 07, 2016 - 11:58 BST